MALDICIÓN TENEMOS UN PROBLEMA; ACTUALIZAR O NO

Tú creces, todos crecemos, estamos hechos para crecer. Tú o evolucionas o desapareces.

– Tupac Shakur, 2pac

 

El día de ayer que se me fue asignado un nuevo proyecto para junglaCODE, una pagina web de AgroGF Plus la cual utilizara el core de WordPress. Pues bien todo parecía marchar en viento de popa, hasta que un extraño mensaje apareció a la hora de instalar nuestro CMS.

WordPress has detected that your site is running on an insecure version of PHP. What is PHP and how does it affect my site?. Traducción WordPress ha detectado que su sitio se ejecuta en una versión insegura de PHP. ¿Qué es PHP y cómo afecta a mi sitio?.

junglacode actualiza php
junglacode actualiza php

En pequeña instancia, claramente se ve que debes de actualizar el lenguaje a una versión mas reciente; pero realmente es así de simple la solución?. La respuesta puede ser variada y esto va depender de como esta la situación en tu servidor; Un ejemplo claro es que en una empresa donde trabajaba su versión de PHP es la 4.x, esta no puede actualizarse por que sus sistemas tiene tecnología obsoleta actualizar seria la muerte de varios de sus módulos que hacen la operación diaria, convirtiéndole  así en un sistema legancy, Pero tarde que temprano la tecnología de terceros va pedir la actualización. Estáis preparado.

Problema.

Resulta que wordpress es uno de esos software de tercero que la jungla usa para desarrollo de paginas web, pues bien ellos al tener sus políticas de seguridad hacen recomendaciones para que los sitios que sean instalados, funcionen correctamente y uno de esos requerimientos es que debe tener PHP 7.x o posterior. Por el momento es solo una aviso, pero como dije anteriormente ellos tienen sus propias reglas y en determinado versión que que ya deje de ser recomendación para convertirse en un requerimiento.

Si vamos a foros te dirán que solo es cuestión de actualizar el php y listo. Y si,  esa es la solución rápida, Pero te has preguntado que si todos los plugins que has instalado soportaran dicha versión de php. O si su tema actual es adaptable a esa versión. Compliquemos un poco las cosas que pasa si un servidor tienes instalado 4 sistemas y uno de ellos tiene la versión 5.1 , otro la 4 y así sucesivamente. Que va pasar si actualizas; Funcionara?. Y todo esto se reduce a un simple. ¿ Realmente actualizar el php garantiza la solución de mi problema ?

Solución

Actualmente tenemos 3 paginas alojada en un servidor que tenemos en la nube. Ambas de estas funciona con PHP 5.6. No hemos actualizado la versión mas actual de wordpress así que lo que hicimos fue lo siguiente.

  • Actualizar todos nuestros sitios a la ultima versión del CMS. Y como wordpress nos indica que si el tema soporta dicha versión. Garantizamos así el funcionamiento correcto de la pagina .
  • Después actualizamos. Nuestro PHP a la version 7.x. Para que así todos nuestro sitios manejen los diferentes complementos a esta versión
  • Verificamos nuestros plugins.  Y rogar que no mande algún tipo de mensaje sobre dicho update . Y es aquí donde WordPress es el amo que otros. Y es que si algo tiene este CMS es que identifica que problemas pueda tener tus plugins y si tiene problemas con una nueva versión solo desinstala y busca otro que haga la misma función ó mejor aun actualizas el plugin y haces crecer la comunidad.

Al parecer la actualización no afecto mucho a los demás sitios , y es que wordpress es un sistema muy escalable que te permite detectar posibles errores, la recomendación que siempre hago cuando tenemos software de terceros, es que siempre estemos atentos a los cambios que estos hagan, ya que actualizar solo por hacerlo puede que joda nuestros sistemas.

Actualizar PHP en CPANEL

junglacode cpanel
junglacode cpanel

Ingresamos a nuestro cpanel y una vez estando dentro buscamos la sección de software, nos vamos a la opción Seleccionar Versión PHP

 

Una vez dentro aparecerá las versiones que quiere que su sitio tenga, Ahora bien si se tiene problemas con actualizar todo su sitio puede usar  la opción, Administrador MutiPHP, esto para que cada dominio que use tenga su propia versión.No ponemos esa opción por que no es lo que nosotros queremos ya que tener 3 o 2 sistemas con diferentes versiones mas contraproducente para nuestra psique. Ja.

Conclusión

Bueno ahora que sabemos que no todo es actualizar y listo, o también no usar el lema si todo funcionan dejarlo así. Todo es cuestión de vulnerabilidades. Solo nos queda recomendar que visiten siempre sus software de tercero para que vean sus planes y así tener también los nuestros y estar siempre preparados para el cambio. Por que aquí el que no evoluciona muere. Nos vemos y hasta próxima…

Referencias.

Requirements

https://wordpress.org/support/topic/wordpress-has-detected-that-your-site-is-running-on-an-insecure-version-of-php/

https://www.php.net/manual/es/migration70.new-features.php

Las actualizaciones de software son críticas, automatízalas

 

 

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *